trouble w/ internet sharing on 1.4.12

Murus
Post Reply
kainotes
Posts: 5
Joined: Tue Jan 02, 2018 6:32 pm

trouble w/ internet sharing on 1.4.12

Post by kainotes » Tue Jan 02, 2018 6:38 pm

I have Murus 1.4.12 and am following the directions to share my internet connection from en0 (static IP connected to Comcast modem/router) through en3. Both the client and server are macOS High Sierra 10.13.1. I am successfully able to share it via System Preferences -> Sharing. Regardless of Murus, I am able to use en3 as a network device and ssh into the host over it -- just cannot share internet.

After resetting pf to its default state via Murus, installing boot scripts, and restarting, I create an NAT group with 10.0.0.25/32 (en3's IP) with access to all services. I then attempt to share internet connection from en0 (WAN interface) to en3.

On the client machine with its own static IP of 10.0.0.234 and router of 10.0.0.25, I am able to ping and ssh into 10.0.0.25 but do nothing else. When I sniff en3 via Murus I can see my attempts to ping 8.8.8.8 but everything times out on the client. The relevant pf rules Murus is generating are as follows:

table <NatLanInterfaces> { en3 }
pass net photo {tcp, udp} from {10.0.0.25/32 } to !<NATLanInterfaces
Can anyone see what I need to add or fix to let 10.0.0.234 access the WAN?

Further discussion on this at:
https://apple.stackexchange.com/questio ... ot-working

kainotes
Posts: 5
Joined: Tue Jan 02, 2018 6:32 pm

Re: trouble w/ internet sharing on 1.4.12

Post by kainotes » Fri Jan 12, 2018 1:24 am

Just so you know I got this to work. The issue seemed to be that I was sharing (via Murus) my internet connection to my network adapter's IP, not the client machine's IP.

Post Reply