Page 1 of 1

Murus keeps quitting

Posted: Mon Feb 05, 2018 3:06 pm
by Gvno
I'm having trouble keeping the Murus app active. Every time I try to open it it quits after a short time. I usually get as far as the "Murus configuration file may be corrupted" message but now it won't even get that far and quits almost immediately.

I first noticed the problem yesterday when I tried to adjust the Murus settings for FaceTime. I clicked "Fix Murus" in the popup window followed by a "Configuration has been restored. Click OK to run Murus" window, but soon ran into problems.

I attempted to fix the problem by trashing the it.murus.muruslibrary.plist file in /Library/Preferences and rebooted. No improvement so I then ran OnyX in automation mode and again rebooted. Again, no improvement. Finally I uninstalled Murus from the menu bar and did a search for any remaining files related to Murus.

I reinstalled Murus and went through the configuration set up keeping all the settings as default. It seemed to be ok but I uninstalled the bootscripts and then reinstalled just to be on the safe side. I rebooted and opened Murus a few times during the day and all was well so I then decided I'd try to adjust the settings again. But it crashed when I tried sliding the 'level-of-security' slider along and now I'm back to square one.

Once again I trashed the it.murus.muruslibrary.plist file and repaired permissions using Onyx but Murus refuses to stay alive even after that. Would appreciate some help on how to fix this.

Using OS X 10.11.6, Murus 1.4.15 (Basic)

NB: I also downloaded and tried another zip file (from in case the first one I kept as a backup was corrupted.

Re: Murus keeps quitting

Posted: Mon Feb 05, 2018 11:58 pm
by Gvno
Here's the first part of the user report from the Console

Time Awake Since Boot: 890 seconds

System Integrity Protection: enabled

Crashed Thread: 6 Dispatch queue:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[__NSDictionaryM objectAtIndexedSubscript:]: unrecognized selector sent to instance 0x7fd351482b60'
abort() called
terminating with uncaught exception of type NSException

Re: Murus keeps quitting

Posted: Tue Feb 06, 2018 6:06 am
by Gvno
I downgraded to Murus 1.4.11 and the problem now seems resolved. (Thanks for the link Hany)