Internet sharing doesn't work(((

Murus
Post Reply
mobalex
Posts: 2
Joined: Mon Mar 30, 2015 11:31 pm

Internet sharing doesn't work(((

Post by mobalex » Tue Mar 31, 2015 6:43 am

Hello!
Yesterday I bought this wonderful software and I wanna say thanks to all developers and programmers for it!)
But unfortunately it doesn't work in my hands)))) I have Mac mini and pptp connection to my provider and I need to share mac's internet connection to local network. I tried to use nat settings but nothing has changed.
Sorry for my English, I'm from Russia. Please tell me what other information do you need about my network and settings of my mac and let's try to find out together!))))
P.S. I have the latest beta of Yosemite and Server app, Mac mini 2012 late
You do not have the required permissions to view the files attached to this post.

hany
Posts: 485
Joined: Wed Dec 10, 2014 5:20 pm

Re: Internet sharing doesn't work(((

Post by hany » Wed Apr 01, 2015 3:35 pm

Hello mobalex,
thank you for joining us :)
I see your scheme but it is not perfectly clear to me. For example the ethernet connection between your macmini and your zyxel switch is the LAN side, not the WAN as depicted. Then I don't understand what do you mean "pptp connection"? I'm guessing you have a normal routed connection to the internet and also a connection to a pptp vpn, is that right?

So as far as I understand:
1) you have a macmini with thunderbolt/ethernet adapter connected to a router (this is the WAN)
2) you have a switch/wifi connected to your macmini's ethernet (this is the LAN)

I need you to tell me some more info about how you did assign IP addresses to LAN and WAN interfaces, and how you setup your clients (PC1, PC2..).
Maybe you can try issuing the

Code: Select all

ifconfig
shell command in Terminal.app and show me the full output.

Thanks!

mobalex
Posts: 2
Joined: Mon Mar 30, 2015 11:31 pm

Re: Internet sharing doesn't work(((

Post by mobalex » Wed Apr 01, 2015 5:49 pm

Ok, while I've been waiting for answers, I reconfigured my local network... so now I connected my mac mini into local, and my router zyxel gives me internet from provider...I did it to make it more clear and to have an internet while I have some experiments with murus))))). So anyway it doesn't work and I can't share an internet in vlan interface. Here's result of ifconfig as you asked
  • Last login: Wed Apr 1 20:26:21 on ttys000
    Mac-mini-Server:~ server$ ifconfig
    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128
    inet 127.0.0.1 netmask 0xff000000
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    nd6 options=1<PERFORMNUD>
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
    ether 68:5b:35:b3:59:22
    inet6 fe80::6a5b:35ff:feb3:5922%en0 prefixlen 64 scopeid 0x4
    inet 192.168.1.37 netmask 0xffffff00 broadcast 192.168.1.255
    nd6 options=1<PERFORMNUD>
    media: autoselect (1000baseT <full-duplex,flow-control,energy-efficient-ethernet>)
    status: active
    en4: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
    ether ac:87:a3:05:4c:8d
    nd6 options=1<PERFORMNUD>
    media: autoselect (none)
    status: inactive
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 44:fb:42:ff:fe:db:5e:66
    nd6 options=1<PERFORMNUD>
    media: autoselect <full-duplex>
    status: inactive
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether a8:86:dd:a7:5a:49
    inet6 fe80::aa86:ddff:fea7:5a49%en1 prefixlen 64 scopeid 0x7
    inet 169.254.253.74 netmask 0xffff0000 broadcast 169.254.255.255
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
    en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether 32:00:1d:b5:e6:60
    media: autoselect <full-duplex>
    status: inactive
    p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 0a:86:dd:a7:5a:49
    media: autoselect
    status: inactive
    awdl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1452
    ether d6:6f:e5:fe:eb:d8
    inet6 fe80::d46f:e5ff:fefe:ebd8%awdl0 prefixlen 64 scopeid 0xa
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
    pflog0: flags=141<UP,RUNNING,PROMISC> mtu 33088
    bridge100: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=3<RXCSUM,TXCSUM>
    ether 6a:5b:35:3b:b7:64
    inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    inet6 fe80::685b:35ff:fe3b:b764%bridge100 prefixlen 64 scopeid 0xc
    Configuration:
    id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
    maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
    root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
    ipfilter disabled flags 0x2
    member: en4 flags=3<LEARNING,DISCOVER>
    ifmaxaddr 0 port 5 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: <unknown type>
    status: inactive
    bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether 6a:5b:35:3b:b7:00
    Configuration:
    id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
    maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
    root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
    ipfilter disabled flags 0x2
    member: en2 flags=3<LEARNING,DISCOVER>
    ifmaxaddr 0 port 8 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: <unknown type>
    status: inactive
    utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380
    inet6 fe80::38f4:b654:67e3:599b%utun0 prefixlen 64 scopeid 0xe
    inet6 fdda:315:ea69:1362:38f4:b654:67e3:599b prefixlen 64
    nd6 options=1<PERFORMNUD>
    Mac-mini-Server:~ server$

hany
Posts: 485
Joined: Wed Dec 10, 2014 5:20 pm

Re: Internet sharing doesn't work(((

Post by hany » Thu Apr 02, 2015 1:18 pm

hello,
first of all
bridge100: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=3<RXCSUM,TXCSUM>
ether 6a:5b:35:3b:b7:64
inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
it seems that you have activated the Internet Sharing option in OS X System Preferences. You have to disable it if you want to share internet using murus NAT.
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
ether 68:5b:35:b3:59:22
inet6 fe80::6a5b:35ff:feb3:5922%en0 prefixlen 64 scopeid 0x4
inet 192.168.1.37 netmask 0xffffff00 broadcast 192.168.1.255
I think this is the built-in ethernet interface.

en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether a8:86:dd:a7:5a:49
inet6 fe80::aa86:ddff:fea7:5a49%en1 prefixlen 64 scopeid 0x7
inet 169.254.253.74 netmask 0xffff0000 broadcast 169.254.255.255
I think this is wifi, maybe. It has a local address, probably because it does not find a dhcp server. If you want to use this interface, then you have to setup manually with a static ip.
en4: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
ether ac:87:a3:05:4c:8d
nd6 options=1<PERFORMNUD>
media: autoselect (none)
status: inactive
this should be your thunderbolt-ethernet adapter, and it seems it is not configured.

So there is a bit of confusion :) You have to disable all dhcp and assign all addresses manually, to your mac and to all clients.
Then you have to split your network in 2 sides: wan and lan. Clients must stay in the lan network, your router in the wan network, while your mac running murus stays on both sides because it has 2 interfaces, wan and lan.
Your mac running murus must set is wan as primary interface, configuring ip, subnet, router and dns.
Then you set the lan interface, only with ip and subnet. You will use this ip address as router on all your clients.

Post Reply