Turning off and on internet sharing starts Murus.

Murus
Post Reply
NEO1
Posts: 16
Joined: Mon Jun 01, 2015 7:21 am

Turning off and on internet sharing starts Murus.

Post by NEO1 » Mon Jun 01, 2015 7:26 am

Hi

Setup:

1. OSX System Preferences => Sharing => Internet sharing on
2. Stop Murus on stop button
3. Internet sharing stops working. I assume OSX gets confused with the rules or something.
4. OSX => System Preferences => Sharing => Toggle internet sharing off and then on.
5. FOr some reason Murus now auto starts...?

In step 5, should it really? How do I disable this behaviour. Hard to troubleshoot if you can't force it off.

hany
Posts: 481
Joined: Wed Dec 10, 2014 5:20 pm

Re: Turning off and on internet sharing starts Murus.

Post by hany » Mon Jun 01, 2015 3:21 pm

Short answer: System Preferences Internet Sharing is not supported by Murus (see manual). To share Internet connections using Murus you have to use Murus NAT. Murus NAT is available only in Murus Pro.

Long answer:
1. OSX System Preferences => Sharing => Internet sharing on
2. Stop Murus on stop button
3. Internet sharing stops working. I assume OSX gets confused with the rules or something.
4. OSX => System Preferences => Sharing => Toggle internet sharing off and then on.
5. FOr some reason Murus now auto starts...?
PF is part of the OS X core. System Preferences' Internet Sharing uses PF and NatPMP to share your Internet connection.
When you toggle Internet Sharing you are not "starting Murus", you are "starting PF". Murus sees PF as active.
Only one PF ruleset can be activated. Murus is used to configure the PF ruleset. When you activate Murus you are telling OS X to run PF using the configuration created by Murus. Whatever way you use to enable/disable it, PF will load this ruleset unless you tell it do load something else.
So if you toggle System Preferences Internet Sharing, OS X starts PF. OS X is not aware of "which PF ruleset is being activated". So, if a Murus ruleset is active, System Preferences' Internet Sharing won't work, because Murus pretends to share the Internet connection in a different way, which is not compatible. In order to use System Preferences Internet Sharing you have to re-enable default OS X PF ruleset uninstalling Murus or issuing this shell command from terminal:

Code: Select all

sudo pfctl -ef /etc/pf.conf
Probably we will put a button or a menu item in next Murus release to simplify this, without the need to type a shell command

Post Reply