Logs Visualize troubleshooting

Murus
Post Reply
avalon
Posts: 3
Joined: Tue Jun 02, 2015 7:53 am

Logs Visualize troubleshooting

Post by avalon » Tue Jun 02, 2015 11:10 am

Hi,
my Logs Visualizer is blank. How can I try to troubleshoot?

thanks.
You do not have the required permissions to view the files attached to this post.

hany
Posts: 474
Joined: Wed Dec 10, 2014 5:20 pm

Re: Logs Visualize troubleshooting

Post by hany » Tue Jun 02, 2015 12:32 pm

Murus Logs Visualizer displays an empty log view (in Simplified Logs window) if it does not find PF file log at /var/log/pffirewall.log, if this file is empty or if it has wrong permissions.
So first of all you should check if /var/log/pffirewall.log file exists. If it does please look at its permissions; it should be readable by everyone.

If /var/log/pffirewall.log does not exists then probably you did not activate the logging system. You have to install Murus boot scripts and reboot. You can do it from Murus "Firewall" menu. Boot scripts are mandatory because they start tcpdump and create the needed pflog0 interface.

If /var/log/pffirewall.log exists but it's empty then you need to make some logged connections in order to produce logs. Set Murus accordingly and do some connections. Murus Logs Visualizer's simplified logs view should populate in real time.

If /var/log/pffirewall.log exists, is not empty, and has correct permissions but you still don't see anything in Murus Logs Visualizer then please try to fix your System Disk and privileges using third party tools like Onyx or Cocktail.

Please let me know :)

avalon
Posts: 3
Joined: Tue Jun 02, 2015 7:53 am

Re: Logs Visualize troubleshooting

Post by avalon » Wed Jun 03, 2015 5:26 am

all done but Murus Logs Visualizer displays is still empty.

some suggests ?
You do not have the required permissions to view the files attached to this post.

hany
Posts: 474
Joined: Wed Dec 10, 2014 5:20 pm

Re: Logs Visualize troubleshooting

Post by hany » Wed Jun 03, 2015 10:53 am

I see from your first screenshot that the "Read Lines" toolbar slider is set to 50 (default value).
Probably you have to increase this slider value to display some log lines.
Murus Logs Visualizer's Simplified Logs View ignores some (less important, like broacast traffic) log lines, this may be the reason why you don't see anything.

Increase the slider to 200-300-1000 and please let me know :)

P.S.
this was the first thing to try, but I forgot to mention it, please forgive me.

avalon
Posts: 3
Joined: Tue Jun 02, 2015 7:53 am

Re: Logs Visualize troubleshooting

Post by avalon » Wed Jun 03, 2015 11:37 am

It works.

Thanks.

hany
Posts: 474
Joined: Wed Dec 10, 2014 5:20 pm

Re: Logs Visualize troubleshooting

Post by hany » Wed Jun 03, 2015 8:29 pm

That's great :)
You're welcome, enjoy!

Post Reply