Murus Lite hangs after trying to apply pf rules

Murus
Post Reply
alcimedes
Posts: 2
Joined: Wed Jun 15, 2016 4:55 pm

Murus Lite hangs after trying to apply pf rules

Post by alcimedes » Wed Jun 15, 2016 5:06 pm

Just wondering if there are any known issues where Murus will hang after you try to apply the pf rules.

I'm able to create custom groups, save, relaunch the application with no problems. However, once I try to apply any pf rules (either custom ones I've made or the defaults it comes with) the app. hangs after trying to apply the pf rules.

The rules are being applied on a local machine.

I tried applying the rules as both a local setup or as if it were over VNC (and supposed to reset after 60 seconds of no activity) but the app. hangs in both cases for 10+ min before I force quit.

I found in a google search a reference to a debug version of 1.2, I was wondering if there's something similar for the current version, or any other suggestions you may have. Thanks in advance, and this looks like a wonderful tool.

hany
Posts: 482
Joined: Wed Dec 10, 2014 5:20 pm

Re: Murus Lite hangs after trying to apply pf rules

Post by hany » Thu Jun 16, 2016 12:55 pm

that's strange, please restore default Murus configuration from "Firewall" menu in OS X menu bar, then click PLAY without modifying anything.
If it hangs again then please provide us some more information about your Mac (os version and such).
Thanks

alcimedes
Posts: 2
Joined: Wed Jun 15, 2016 4:55 pm

Re: Murus Lite hangs after trying to apply pf rules

Post by alcimedes » Thu Jun 16, 2016 3:02 pm

I did a little playing around, and digging through old threads.

Running the latest version of Onyx seemed to do the trick, and now the rules apply with no issues.

I have what I hope is one last, simple question though. I'm trying to limit the amount of bandwidth at work dedicated to music/video streaming. I've been trying to get Netflix throttled for example, but I can't figure out which rules I would want to apply to actually make that happen, and I haven't seen anyone else restricting Netflix to start from.

Any recommendations on where to start?

edit: What I've tried.

I found a list of all the IP addresses that Netflix uses. I made a group called "netflix_streaming" and added the IP's to that list (and validated them)

I then added the "netflix_streaming" group to the "Blocked Groups" section of the "All Services" option. However, Netflix still streams just fine.

I verified pf was running, using both Murus (which said it was enabled) and using the command line to fire it up once to ensure it was active.
Armand:~$ sudo pfctl -E
Password:
No ALTQ support in kernel
ALTQ related functions disabled
pf enabled
Token : XXXXXXXXXXXXX
(nuked the token value in case it matters, it was a random string of numbers though)

Post Reply