Murus Menulet icon not showing in menubar

Murus
Post Reply
mbogart
Posts: 4
Joined: Fri Sep 02, 2016 5:55 pm

Murus Menulet icon not showing in menubar

Post by mbogart » Fri Sep 02, 2016 6:18 pm

Using OS X 10.11.6, I am not able to get the Murus Menulet icon to appear in the menubar. I get the popup message "Murus Menulet daemon is not running." when I attempt to open the program, after I click that, it appears to be running, but no icon appears. I have tried versions 1.1 and 1.0 of Murus Menulet downloaded directly from the Murus site, neither appears, even after rebooting. This occurs regardless of whether Murus PF is installed and running or not. I don't know if this is a conflict with another application or Mac setting or recent update. Icefloor and its own menu icon appear to work OK, but I prefer Murus if I can get its menulet to work. Thank you for your assistance.

wighta157
Posts: 3
Joined: Sat May 16, 2015 6:25 am
Location: USA

Re: Murus Menulet icon not showing in menubar

Post by wighta157 » Mon Sep 05, 2016 1:24 pm

I too am running OS X 10.11.6 and Murus 1.4.3 , and Murus Menulet 1.1. But the Murus Menulet icon shows on my menubar, and it functions normally for me.

hany
Posts: 480
Joined: Wed Dec 10, 2014 5:20 pm

Re: Murus Menulet icon not showing in menubar

Post by hany » Wed Sep 07, 2016 12:04 pm

Please try reinstalling Murus Menulet.
If it still does not work then there probably something wrong with OS X caches or something. Run a legit OS X cleaning utility like Onyx or Cocktail then retry.

mbogart
Posts: 4
Joined: Fri Sep 02, 2016 5:55 pm

Re: Murus Menulet icon not showing in menubar

Post by mbogart » Wed Sep 07, 2016 8:25 pm

hany wrote:Please try reinstalling Murus Menulet.
If it still does not work then there probably something wrong with OS X caches or something. Run a legit OS X cleaning utility like Onyx or Cocktail then retry.
Thank you for you reply. After uninstalling Murus Menulet 1.1, I ran the Onyx automation (everything checked), rebooted and downloaded Murus Menulet again from this site while in an admin profile. When I click the Murus Menulet icon for the 1st time, I get the popup "Murus Menulet daemon is not running." After I hit the "Run Murus Menulet daemon" option, I get a 2nd popup: "Murus Menulet daemon installed. Murus Menulet is available in the OSX menubar, near the clock." After I hit the "Ok" button, there is no icon for the menulet, but it is running, I can click a blank space in the menu left of the other menubar icons, to get the menulet's drop down menu. Also, whenever I restart the computer or logout and switch profiles, the menulet is not running at all, and I have to click the application icon and go through the pop-ups again. At no point am I able to get the menulet icon to appear in the menubar.

This is happening on 2 different computers, I'm not sure if I didn't install correctly, or there is a Mac setting or application that is causing this.

I am running OSX 10.11.6 and Murus 1.4.2

[img]Backstop%20Menubar%202016-09-07%2012-42-23.png[/img]

mbogart
Posts: 4
Joined: Fri Sep 02, 2016 5:55 pm

Re: Murus Menulet icon not showing in menubar

Post by mbogart » Wed Sep 07, 2016 8:33 pm

I've attempted to attach a screen shot of what I am talking about, I apologize if I didn't do this correctly.
You do not have the required permissions to view the files attached to this post.

hany
Posts: 480
Joined: Wed Dec 10, 2014 5:20 pm

Re: Murus Menulet icon not showing in menubar

Post by hany » Fri Sep 09, 2016 5:09 pm

oook that's really strange.....
I think the reason for your issue is inside the launcher script in /Library/LaunchDaemons/it.murus.murusd.plist
probably you installed using a non admin password?

please do this:
select "info about menulet" then click the "uninstall" button.
Reinstall it but please be sure to use an administrator password to install it.
After that please verify that file /usr/local/bin/murusd exists. Then please let me know :)

mbogart
Posts: 4
Joined: Fri Sep 02, 2016 5:55 pm

Re: Murus Menulet icon not showing in menubar

Post by mbogart » Fri Sep 09, 2016 11:09 pm

hany wrote:oook that's really strange.....
I think the reason for your issue is inside the launcher script in /Library/LaunchDaemons/it.murus.murusd.plist
probably you installed using a non admin password?

please do this:
select "info about menulet" then click the "uninstall" button.
Reinstall it but please be sure to use an administrator password to install it.
After that please verify that file /usr/local/bin/murusd exists. Then please let me know :)
Thanks hany, selecting the uninstall button from the dropdown before reinstalling Murus Menulet fixed the issue.

hany
Posts: 480
Joined: Wed Dec 10, 2014 5:20 pm

Re: Murus Menulet icon not showing in menubar

Post by hany » Sat Sep 10, 2016 1:16 pm

that's great :)

Post Reply