Vallum 2.1 crash

Vallum application firewall
Post Reply
megumi
Posts: 34
Joined: Wed Dec 31, 2014 2:31 pm

Vallum 2.1 crash

Post by megumi » Wed May 24, 2017 5:35 pm

Hello hany,

I have been running Vallum 2.1without any problem until recently, when I noticed 2.2.1 was out. I downloaded 2.2.1 and installed it. After reboot, Vallum opened to ask for configuration, but when I apply the configuration, Vallum crashes almost straight away, sometimes silently (showing spinning beachball only when mouse pointer is over the Vallum menulet) and at other times displaying the dialogue box saying "Vallum Agent has quit unexpectedly". If I click the button to restart Vallum Agent, it crashes often immediately, but sometimes after showing the configuration window again.

I used the standalone uninstaller to remove 2.2.1. and reinstalled 2.1 hoping that 2.1 would work as it used to. Strangely enough, now 2.1 crashes in the same way as 2.2.1. I have no idea why this has happened. There is no new software I installed recently, and as far as I know I have not changed anything. Do you have any idea?

Megumi
Screen Shot 2017-05-24 at 17.36.17.png
You do not have the required permissions to view the files attached to this post.

hany
Posts: 409
Joined: Wed Dec 10, 2014 5:20 pm

Re: Vallum 2.1 crash

Post by hany » Sat May 27, 2017 1:15 pm

Hello megumi,
I'm sorry this is really strange, I don't know why it happened.
Probably the only way for us to troubleshoot this issue is to see crash logs.
You should be able to find a Vallum crash log using macOS Console.app, in "user reports". Can you please have a look at it and send us a crash log file?
Thank you !

megumi
Posts: 34
Joined: Wed Dec 31, 2014 2:31 pm

Re: Vallum 2.1 crash

Post by megumi » Sat May 27, 2017 4:34 pm

Hello hany,

I am attaching a ZIP archive "CrashLogsArchive.zip", which contains 4 crash log files. The newest one is with Vallum 2.1. Other 3 are with Vallum 2.2.1. I hope they make sense to you.
You do not have the required permissions to view the files attached to this post.

megumi
Posts: 34
Joined: Wed Dec 31, 2014 2:31 pm

Re: Vallum 2.1 crash

Post by megumi » Thu Jun 08, 2017 10:18 am

Hello hany,

Just to update (for the benefit of others who might have the same problem), having followed your suggestions in the private email exchange, I have now come to the conclusion that Vallum crash was caused by software incompatibility. My investigation led me to conclude that Vallum somehow clashes with a Safari extension, JS Blocker 5 (v.5.1.7). Once I disabled it (without uninstalling it), Vallum seems to run fine.

Ideally, I would like to use JS Blocker in Safari, so I hope this apparent incompatibility would be fixed, but for now, I am happy to be able to run Vallum. Thank you for your help.

Megumi

megumi
Posts: 34
Joined: Wed Dec 31, 2014 2:31 pm

Re: Vallum 2.1 crash

Post by megumi » Thu Jun 08, 2017 12:08 pm

Ok. Perhaps I spoke too soon. My problem is continuing. Vallum works fine with Safari (with JS Blocker turned off), and I can browse various sites. (As I post this here, I am doing so in Safari, and Vallum is working perfectly well.) HOWEVER, as soon as I visit SOME SITES, the dialogue box appears saying "Vallum Agent quit unexpectedly", and I have to restart Vallum agent AFTER I quit Safari. It's very strange. Why should it make any difference to an application firewall which website I visit? I have no idea. Out of interest, I tried Chromium browser and found that Vallum crashes as soon as I start Chromium. I have not yet figured out if it's Chromium or something I use with Chromium (extension/plugin?).

So, just to update again, my struggle with Vallum continues. But I am pretty sure it's some kind of compatibility issue with Vallum and something else. I just have not found what exactly is causing the problem. I hope you (hany) can figure out what's going on and fix the issue.

Megumi

megumi
Posts: 34
Joined: Wed Dec 31, 2014 2:31 pm

Re: Vallum 2.1 crash

Post by megumi » Thu Jun 08, 2017 1:54 pm

Another Update
After trying different things, I learned that Vallum crashes with other applications that make internet connections (like FTP or WhatApp messaging). I eventually came to suspect that Vallum crashes when it is supposed to ask for my user input to decide whether an application is allowed to make a connection. I realise that Vallum has not asked me for a user input even once since this crash issue started. Then I started checking how I configured Vallum, and I noticed that I have checked "Enable interaction with Murus" in the preferences. I remember now that I decided to try checking it out of curiosity not long ago when I updated Vallum from 2.1 to 2.2.1. That's exactly when my crashing problem started.

I have now unchecked the option, and everything is working well. I have re-enabled all my Safari extensions and I can visit any web sites without any problem. It looks like the real cause of the problem was checking the option for Vallum to interact with Murus.

I am not sure what is meant to happen when Vallum interact with Murus, but that feature does not seem to be working well. Still, without that interaction, both Murus and Vallum are working fine doing their jobs, and I am happy with that.

Megumi

hany
Posts: 409
Joined: Wed Dec 10, 2014 5:20 pm

Re: Vallum 2.1 crash

Post by hany » Sat Jun 24, 2017 8:32 pm

The issue has been fixed in Vallum 2.3.

Post Reply