Vallum stopped working after an OS upgrade

Vallum application firewall
Post Reply
yakyu
Posts: 3
Joined: Fri Dec 21, 2018 5:19 am

Vallum stopped working after an OS upgrade

Post by yakyu » Tue Nov 12, 2019 2:37 am

Forgive me, but I didn't notice exactly when this happened as I had Vallum set up nicely enough that it rarely interceded, but I had a separate problem with my machine today and noticed it was not and would not run.

System: 10.14.6
Vallum: 3.3.1

The error message in the logs is:

error 11:15:46.117791 +0900
tccd
Prompting policy for hardened runtime; service: kTCCServiceAppleEvents requires entitlement com.apple.security.automation.apple-events but it is missing for ACC:{ID: it.murus.afw.Vallum, PID[2464], auid: 501, euid: 501, binary path: '/Library/Application Support/Vallum/Client/Vallum.app/Contents/MacOS/Vallum'}, REQ:{ID: com.apple.appleeventsd, PID[77], auid: 55, euid: 55, binary path: '/System/Library/CoreServices/appleeventsd'}

Murus runs fine. I can't find anywhere to enable this and I'm wondering if it's a code signing issue. This could be relevant? https://forum.xojo.com/55310-how-to-add ... codesign/0

Any help or insight would be much appreciated.

Regards,
iain

yakyu
Posts: 3
Joined: Fri Dec 21, 2018 5:19 am

Re: Vallum stopped working after an OS upgrade

Post by yakyu » Tue Nov 12, 2019 2:40 am

Also, this linked Apple documentation makes me wonder why Vallum requires this

https://developer.apple.com/documentati ... ple-events

> Apple Events Entitlement
> A Boolean value that indicates whether the app may prompt the user for permission to send Apple Events to other apps.

Regards,
iain

Post Reply